$re = '/(?<MyGroup> 4\/(.+?)(?=(?: \d\/)|$))/m';
$str = ' 4/abc def 5/abc
4/abc def';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);