#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([0-9]{2}:){3}[0-9]{2}"
Local $sString = "@ This file written with the Avid Caption plugin, version 1" & @CRLF & _
"" & @CRLF & _
"<begin subtitles>" & @CRLF & _
"00:00:08:00 00:00:14:03" & @CRLF & _
"070" & @CRLF & _
"" & @CRLF & _
"00:00:14:03 00:01:02:19" & @CRLF & _
"085" & @CRLF & _
"" & @CRLF & _
"00:01:02:19 00:01:37:04" & @CRLF & _
"075" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")