using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{2}:){3}[0-9]{2}";
string input = @"@ This file written with the Avid Caption plugin, version 1
<begin subtitles>
00:00:08:00 00:00:14:03
070
00:00:14:03 00:01:02:19
085
00:01:02:19 00:01:37:04
075
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}