$re = '/([0-9]{2}:){3}[0-9]{2}/';
$str = '@ This file written with the Avid Caption plugin, version 1
<begin subtitles>
00:00:08:00 00:00:14:03
070
00:00:14:03 00:01:02:19
085
00:01:02:19 00:01:37:04
075
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);