import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{.*?\\}\\}|\\{%.*?%\\}";
final String string = "{% if statement is true %} \n"
+ "The true thing\n"
+ "{% else %}\n"
+ "the false thing\n"
+ "{% endif %} \n\n\n"
+ "{% if {{custom_attribute.${total_spend}}} >0 %}\n"
+ "Thanks for purchasing! Here's another 10% off!\n"
+ "{% else %}\n"
+ "Buy now! Would 5% off convince you?\n"
+ "{% endif %}\n"
+ "----\n\n"
+ "Something something {{userAttribute}} something else.\n\n\n"
+ "Hi {{ ${first_name} | default: 'Valued User' }}, thanks for using the App!\n\n"
+ "-- note that the example had an extra right bracket:\n"
+ "{{${first_name} | capitalize | strip | default: 'friend'}}}\n\n"
+ "{{${first_name} | capitalize | strip | default: 'friend'}}\n\n\n"
+ "-- Suggested more localization friendly method instead of \"default\": --\n\n"
+ "Hello {% if ${first_name} == \"\" %}friend{% else %}{{${first_name}| capitalize | strip}}\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}