const regex = /(?<=(?:.+?[:;]){2})(.+?)[:;]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(?:.+?[:;]){2})(.+?)[:;]', 'g')
const str = `Камера:Разрешение фото и видео:фото: 3840х2160P; видео: 1920х1080P`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);