package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9a-fA-F]+(?:[:-][0-9a-fA-F:]+)*(?:\r?\n[0-9a-fA-F]+(?:[:-][0-9a-fA-F:]+)*)*$`)
var str = `123ABC:DEF456
0:1:2:3:4:5
12345
90210-1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}