#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([a-zA-Z0-9]+):"(.*?)(?<!\\)""
Local $sString = "joe:"Look over there\, it's a shark!",sam:"I like fish.""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)