# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<br><br>(?!<br)/<br>/g;t' <<< "Test1 is here<br><br>Now comes Test2<br><br>Then test 3<br><br><br>Thats it."