import Foundation
let pattern = #"<br><br>(?!<br)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Test1 is here<br><br>Now comes Test2<br><br>Then test 3<br><br><br>Thats it."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<br>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)