package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)&page_number=\d+$`)
var str = `http://url.com/search/?location=london&page_number=1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}