$re = '/&page_number=\d+$/m';
$str = 'http://url.com/search/?location=london&page_number=1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);