# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[[^\]]*u:([^\]]*)\]/<a href='\/user\/\1'>\1<\/a>/gm;t' <<< "Here is a link [u:person]!"