#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[[^\]]*u:([^\]]*)\]"
Local $sString = "Here is a link [u:person]!"
Local $sSubst = "<a href='/user/\1'>\1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)