package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^\]]*u:([^\]]*)\]`)
var str = `Here is a link [u:person]!`
var substitution = "<a href='/user/\1'>\1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}