use strict;
my $str = 'Here is a link [u:person]!';
my $regex = qr/\[[^\]]*u:([^\]]*)\]/mp;
my $subst = '<a href=\'/user/\\1\'>\\1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";