import Foundation
let pattern = #"\[[^\]]*u:([^\]]*)\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Here is a link [u:person]!"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href='/user/\1'>\1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)