using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img [^>]*src=""([^""]+)""";
string input = @"<img src=""http://google.com/q.jpeg""> matched
<img alt=""something"" src=""http://google.com/q.jpeg"">
<audio src=""http://something.."">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}