re = /StatementId:[ ](?:\[([^\[\]]*)\]|(.*?)),.*UserId:[ ]([0-9]*)/
str = 'StatementId: [12345], UserId: 8756
StatementId: 12345, UserId: 8756
StatementId: [12345,6789], UserId: 8756'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end