const regex = /[\r|\n|^<]*(<a([^*>]+>)|<\/a>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\r|\\n|^<]*(<a([^*>]+>)|<\\\/a>)', 'g')
const str = `juabsdfsadfsdfsf<a href=""><h1></h1></a> sdfsdfsdf <h2>sdfsdfs</h2> <div class=""><a href=""></a><div class="block">
<a href="/">
<div class="divInside"></div>
<img src="/bla" /><div class="block">
<a href="/">
<div class="divInside"></div>
<img src="/bla" />
<p>Parargraph<div class="block">
<a href="/">
<div class="divInside"></div>
<img src="/bla" />
<p>Parargraph</p>
</a>
</div></p>
</a>
</div>
<p>Parargraph</p>
</a>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}