import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*'.*?'\\s*=>\\s*('.*?',?)$";
final String string = " 'cpt' => 'application/mac-compactpro',\n"
+ " 'cpt' => 'application/x-compactpro',\n"
+ " 'cpt' => 'application/x-cpt',\n"
+ " 'crl' => 'application/pkcs-crl',\n"
+ " 'crl' => 'application/pkix-crl',\n"
+ " 'crt' => 'application/pkix-cert',\n"
+ " 'crt' => 'application/x-x509-ca-cert',\n"
+ " 'crt' => 'application/x-x509-user-cert',\n"
+ " 'csh' => 'application/x-csh',\n"
+ " 'csh' => 'text/x-script.csh',\n"
+ " 'css' => 'application/x-pointplus',";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}