const regex = /^(?=.{8}$)([1-9]\d*|0)\.\d{1,2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{8}$)([1-9]\\d*|0)\\.\\d{1,2}$', 'gm')
const str = `12345.12
123456.1
12345678
1234567.8
12345.678
123.0
12345678
123.12
1.2345678
12.345678
00010.12
0.12
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}