using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0\d-?\d{4}-?\d{4}";
string input = @"01-2345-6789
0123456789
01-23456789
012345-6789";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}