const regex = /0\d-?\d{4}-?\d{4}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0\\d-?\\d{4}-?\\d{4}', 'g')
const str = `01-2345-6789
0123456789
01-23456789
012345-6789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}