using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Function(.*?)End Function";
string input = @"Function this is the function itself with a End End Function";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}