const regex = /Function(.*?)End Function/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Function(.*?)End Function', '')
const str = `Function this is the function itself with a End End Function`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}