$re = '/Function(.*?)End Function/';
$str = 'Function this is the function itself with a End End Function';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);