package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:\.|#)(?:[a-z]|[A-Z]|[0-9]|\s|\.|#|-|:|&|,)+?{(?:\s|\n)*(?:\/\*export\*\/)(?:.|\n)*?})`)
var str = `.something {
background-color:pink;
}
.somethingelse {
/*export*/
text-align: right;
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}