use strict;
my $str = ':D :D ":D" :D:D:D:D';
my $regex = qr/"[^"]+"(*SKIP)(*F)|:D/p;
my $subst = '^';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";