// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\*(?<group>\w+)\]").unwrap();
let string = "[*A]
[*refname]
Should not match [*A text] as it is already done in the step before.
";
let substitution = "<ref group=\"$group\" />";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}