use strict;
my $str = '/sites/Teams5/Nat_Man_MLP/ufbufuf
/sites/Teams5/connect-HRIS/ignig
/sites/Teams5/C-D/mhmòhm';
my $regex = qr/\/sites\/Teams5\/(?<parent_site>[^\/]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}