// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/sites\/Teams5\/(?<parent_site>[^\/]+)").unwrap();
let string = "/sites/Teams5/Nat_Man_MLP/ufbufuf
/sites/Teams5/connect-HRIS/ignig
/sites/Teams5/C-D/mhmòhm";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}