$re = '/\b(?:MIM#|OMIM:|(?<!:))(\d{6})\b/m';
$str = '111111;Dystonia-1,222222,OMIM:555555; 3333333 Dystonic disorder1,MIM#444444';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);