re = /\b(?:MIM#|OMIM:|(?<!:))(\d{6})\b/m
str = '111111;Dystonia-1,222222,OMIM:555555; 3333333 Dystonic disorder1,MIM#444444'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end