$re = '/(?<=key)\s(?:\d+[\s,]+)+(?:and )?\d+/';
$str = 'some text key 12, 32, 311 ,465 and 345. some other text dog 612,
12, 32, 9 and 10. some text key 1, 2.
a key is dog 3242342342, 345345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);