$re = '/^(\d+)([[:space:]])(.+)$/m';
$str = '1529 33ER TAXI AG
2384 4EYES GMBH';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);