import Foundation
let pattern = #"([\d]{1});([\d]{1});([\w\s\.\d\-\(\)]*);([\w\s\.\d\-\(\)]*);([\w\s\.\d\-\(\)]*);([\w\s\.\d\-\(\)]*);([\w\s\.\d\-\(\)]*);([\w\s\.\d\-\(\)]*);([\dZ-a]*);([\d\sA-Z]*);([\w\s\.\d\-\/\(\)]*);([\w\s\.\d\-\(\)]*);([0-9]*);([0-9]*);([0-9]*);([0-9]*);([0-9]*)[MGB]{2};([\w\s\.\d\-\/\(\)]*);([0-9])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0;1;;Alpha Media Lab;Alpha Media Lab;Administratie;M2M;Haringvliet;68;3011 TG;Rotterdam;8 dagen;700;45;11;30;5MB;;0
0;0;Clear Channel ;Clear Channel Hillenaar ;;Administratie;;;;;;;2250;45;15;30;1GB;;1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"UPDATE [dbo].[Customer]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)