using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<folderorurl>(?<folder>(\\[^\\\s"",<>|]+)+)|(?<url>https?:\/\/[^\s]+))";
string input = @"\server\share
\folder\subfolder\subsubfolder
http://www.test.de
https://example.com
this is another string that does not get matched
what about this line?
and here we have some special characters <> \\<>dsass\<<<>sdadada#++pü+
is it matching this \folder\subfolder thingy?
oh, yes, but what about another strange http://www.url.com ?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}