$re = '/(?<folderorurl>(?<folder>(\\\\[^\\\\\s",<>|]+)+)|(?<url>https?:\/\/[^\s]+))/';
$str = '\\server\\share
\\folder\\subfolder\\subsubfolder
http://www.test.de
https://example.com
this is another string that does not get matched
what about this line?
and here we have some special characters <> \\\\<>dsass\\<<<>sdadada#++pü+
is it matching this \\folder\\subfolder thingy?
oh, yes, but what about another strange http://www.url.com ?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);