#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^"([^"]*\.exe) *" .*"
Local $sString = "C:\directory\sub-directory\service.exe ThisTextNeedsRemoving" & @CRLF & _
"C:\directory\sub-directory\service.exe -ThisTextNeedsRemoving" & @CRLF & _
"C:\directory\sub-directory\service.exe /ThisTextNeedsRemoving" & @CRLF & _
""C:\direct ory\sub-directory\service.exe" ThisTextNeedsRemoving" & @CRLF & _
""C:\direct ory\sub-directory\service.exe" -ThisTextNeedsRemoving" & @CRLF & _
""C:\direct ory\sub-directory\service.exe" /ThisTextNeedsRemoving"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)