using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?\d+(?:_\d+)*(?:\.\d+(?:_\d+)*)?$";
string input = @"1_2.3_4
1
-1
1.2
-1.2
0
0.00
0.1
000_00.00
0000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}