// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^-?\d+(?:_\d+)*(?:\.\d+(?:_\d+)*)?$").unwrap();
let string = "1_2.3_4
1
-1
1.2
-1.2
0
0.00
0.1
000_00.00
0000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}