$re = '/^[A-Za-z].{2}-[A-Za-z].{2}-([0-9]|[0-9].{1}-[0-9].{2})$/m';
$str = 'ABC-DEF-17-021
AB-DEF-17-021
ABC-DEF-1
ABC-DEF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);