// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^- .+\n.+\n.+").unwrap();
let string = "System.Management.Automation.RemoteException
name: CLD:HYB_Z_BASIS_ADMIN_SUPER
description: Basis Administrator
readOnly:
roleReferences:
- roleTemplateAppId: it!b2455
roleTemplateName: AuthGroup_Administrator
name: AuthGroup_Administrator
- roleTemplateAppId: it!b2455
roleTemplateName: AuthGroup_BusinessExpert
name: AuthGroup_BusinessExpert
OK";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}