using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(@[^\[]+)\](\(.*?\))";
string input = @"[@apple](apple) [@banana](banana) asdassa dasd asd asd asd asdas d [asd](asdasd) [@cherry](cherry) **asdasdasd _asdasdsd_** asdasd asd [banana](banana)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}