$re = '/^\w{3,}\s+(?:\w\s+)?\w{3,}/mi';
$str = 'John Doe
John M Doe
John Mr Doe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);