use strict;
my $str = '# Test
| Demo Name / Link | Tweet size description | Key Elements | PRPs / Authors | Video/Recording | Last Updated |
|-----------------------------------------------------------------------------------------------------------------------|-------------------------------------------------------------------------------------------------------------------------------------|-----------------------------------------------------------------------------------------------------------------------|------------------------|---------------------------------------------------------------------------------------------------------------|------------------|
| [Azure Pipelines, Functions and Luis](end-to-end-demos/azure-devops-pipelines) | Great demo to show the power of GitHub with Serverless Functions and the fancy LUIS API. | Azure Pipelines, Azure Functions, Microsoft LUIS and GitHub Flow | @pierluigi | [Video Walkthrough](https://www.youtube.com/watch?v=OrAuvkcuB7Y) | 23/October/2018 |
';
my $regex = qr/^\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)\|([^|]+)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}