#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[._]"
Local $sString = "Sep04_17.00.37.tif Sep04_17.05.54.tif Sep04_17.08.41.tif" & @CRLF & _
"Sep04_17.02.02.tif Sep04_17.07.17.tif" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)