using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{1,2}\s\w+\s(?:\d{4}|\d{2}))";
string input = @"26 March 21 , 19 Feb 2021,12 Feb 21,19 March 21\
2 Mar 21 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}