// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)\b\p{L}+\b").unwrap();
let string = "abalbal_asldad 23sadaskld adasdas3123 abalbal asldad 23 sadaskld 3123 adasdas";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}